Topic / iPhone Jailbreak

Dev Team: iOS 4.0.2 jailbreak not in the works

By on

After the iOS 4.0.2 firmware update – the very same one that patched an exploit that allowed people to jailbreak their iOS device via a PDF – you may have wondered why your jailbroken iPhone no longer was jailbroken. Well we have some news to tell you about it – some very, very bad news. The iPhone Dev Team have announced that they will not release an update that would […]

Android-iPhone hack ready for download

By on

Remember that hack we reported on that had Android running on an iPhone? Well, now than just a YouTube video, with David Wang (or “planetbeing”) teaming up with PC World to write a guide on how to install Android on the Apple machine, and releasing the binaries of the files for the rest of us to try it out. It currently works for any first-generation iPhone or iPhone 3G and […]

iPhone 3GS gets jailbroken

By on

George Hotz (geohot) has announced that he has successfully found a way to jailbreak the iPhone 3GS, following his success to be the first person to successfully unlock the original iPhone, right before the iPhone Dev Team releasing their jailbreak, after the team decided to put their jailbreak on hold for the iPhone 3.1 update. “Normally I don’t make tools for the general public, and rather wait for the dev […]

Guess what iPod touch 2G users – You can now jailbreak your device!

By on

In what may be an “OMFG!” moment for 2009, a forum posting on the iPod Touch Fans website has given out details on how to finally “untether” your “tethered” iPod touch 2G, to the delight of many users who got the new device and been waiting very patiently, like me. However, because of the fact that it hasn’t been packaged into PwnageTool or QuickPwn, the two applications that are commonly […]

iPhone 2.2 jailbroken – still no support for the iPod touch second-gen

By on

There is some good news who want an jailbroken iPhone 3G, you can do it now with the latest update to PwnageTool and QuickPwn from the iPhone Dev Blog. However, there is a catch – if you want to have the potential to use soft unlock, you must NOT use QuickPwn – and not use the official updates without using PwnageTool. As well, it also reports that there is a […]

DevTeam releases QuickPwn and PwnageTool for Firmware 2.1

By on

The iPhone DevTeam has released new versions of their ever-popular QuickPwn and Pwnage Tools for the new iPod/iPhone touch Firmware 2.1. As well, they managed to combat iTunes 8 without patching it, but we will wait for a response from Apple. The tools, however, are only for Macs this time, it is expected that a Windows version is in the works. Also, those who got the iPod touch 2G device […]

iPhone 1.1.2 jailbreak software released

By on

The kind folks over at Conceited Software/Touchfree have now released the jail break program to let you actually do something with your iPhone. According to Engadget, you will need to have a downgraded to (or remained with) Version 1.1.1 to make this work. This then upgrades you with Jailbreak, installs and and then upgrade it to 1.1.2. Kind of neat… huh? Oh, plus you do need to have […]

Can’t jailbreak your UK iPhone…

By on

Gizmodo, via T3, have now said that your new iPhone in the UK comes with Version 1.1.2. Bad thing is that you can’t unlock, or ‘jailbreak’, your iPhone from O2, the carrier of the iPhone in the UK. The biggest standard, however, is that now you can choose from 12 languages and comes with special keyboards for the French and German languages. That’s great for the French and the Germans […]

iPhone hack voids your warranty

By on

According to Engadget, Apple has been chasing down those who have unlocked their iPhone. A recent report has said that a person tried to get their iPhone, filled with third-party apps and unlocked, repaired. Apple refused, saying that “the warranty was voided,” and also saying that it was blacklisted. But the owner allowed him to return it and he got his money back, less the 10% restocking fee.

Thanks for coming onboard!
We're excited to have you.

This form is currently undergoing maintenance. Please try again later.